Load Balancing Menggunakan Metode PCC (Per Connection Classifier)

Pengertian

Per-Connection Classifer merupakan metode yang menspesifikasikan suatu paket menuju gateway suatu koneksi tertentu.
PCC mengelompokkan trafik koneksi yang keluar masuk router menjadi bebrapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan dst-port.
Adapun kelebihan dan kekurangan menggunakan metode PCC antara lain :


Kelebihan :
1. Hubungan antara client dan server lebih terjamin karena menggunakan satu jalur yang sama
2. Tidak merepotkan di end user atau pengguna akhir
3. Render atau streaming di youtube lebih stabil.
Kekurangan :
1. Memungkinkan terjadinya overload di salah satu jalur ISP
2. Ketidak seimbangan penggunaan bandwidth

Alat dan Bahan :
1 perangkat mikrotik RB941-2nD-TC
1 perangkat komputer yang terhubung melalui kabel LAN
2 perangkat komputer yang menjadi sumber internet ke router mikrotik

Latar belakang
pada sebuah sebuah sekolah ingin koneksi bandwidth yang besar tapi dari ISP telah ada aturan bandwidth yang standar.dengan Load Balancing Menggunakan Metode PCC kita akan memisahkan jaringan.dan dengan ini jaringan yang butuh bandwidth besar akan khusus mendapat koneksi ISP1 dan jaringa yang lain bisa mengguakan koneksi ISP2


Tahap pelaksanaan
Admin akan mensetting loadbalance menggunakan topologi di bawah ini.
Sesuai konsep dari metode PCC yaitu per koneksi, jadi disini admin mengarahkan koneksi jaringan ether3 ke ISP1 dan jaringan ether4 mengarah ke ISP2 sesuai metode PCC yakni per koneksi.
Bukan berarti selamanya jaringan lokal akan menggunakan trafik ISP1 tetapi dia lebih di utamakan menggunakan ISP1, apabila ada salah satu ISP yang down maka seluruh client akan di alihkan ke ISP yang aktif (fail over).

1.Setelah itu beri ip pada interface sesuai tujuan masing - masing port
  

2.Oke ini adalah bagian yang terpenting dalam loadbalancing yaitu pengaturan mangle. Saran admin apabila anda akan mensetting loadbalance ini pastinya anda sudah mengetahui Packet Flow Firewall dan anda pernah mensetting Firewall di router miktrotik sehingga anda akan paham alur dan konsep dari loadbalance lebih tepatnya dipengaturan mangle ini.
- Disini kita buat kebijakan bahwa ether3 akan menerima IP 192.168.234.0/24 untuk masuk ke interface ehter3 begitu pun sama untuk ether4

[admin@MikroTik] > /ip firewall mangle 
[admin@MikroTik] /ip firewall mangle> add chain=prerouting dst-address=192.168.234.0/24 action=accept in-interface=ether3
[admin@MikroTik] /ip firewall mangle> add chain=prerouting dst-address=192.168.200.0/24 action=accept in-interface=ether4
-Disni kita akan menandai koneksi yang input maupun forward dari ether1 dan ether 2
[admin@MikroTik] /ip firewall mangle> add chain=prerouting in-interface=ether1 connection-mark=no-mark action=mark-connection new-connection-mark=ISP_conn
[admin@MikroTik] /ip firewall mangle> add chain=prerouting in-interface=ether1 connection-mark=no-mark action=mark-connection new-connection-mark=ISP2_conn
 - Action mark-routing hanya dapat digunakan pada chain output dan prerouting, tapi chain mangle prerouting berfungsi menangkap semua lalu lintas yang akan ke router itu sendiri. Untuk menghindari hal ini kita akan menggunakan dst-address-type=!Local. Dan dengan bantuan dari PCC baru kita akan membagi lalu lintas menjadi dua kelompok berdasarkan sumber dan tujuan penerima.
[admin@MikroTik] /ip firewall mangle> add chain=prerouting in-interface=ether3 connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=ISP_conn
[admin@MikroTik] /ip firewall mangle> add chain=prerouting in-interface=ether4 connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=ISP2_conn
 - Disini kita membuat rute lalu lintas yang menuju ke luar dari router ke lokal maupun internet.
[admin@MikroTik] /ip firewall mangle> add chain=prerouting connection-mark=ISP_conn in-interface=ether3 action=mark-routing new-routing-mark=to_ISP 
[admin@MikroTik] /ip firewall mangle> add chain=prerouting connection-mark=ISP2_conn in-interface=ether4 action=mark-routing new-routing-mark=to_ISP2
[admin@MikroTik] /ip firewall mangle> add chain=output connection-mark=ISP_conn action=mark-routing new-routing-mark=to_ISP
[admin@MikroTik] /ip firewall mangle> add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2
3 Langkah selanjutnya kita mentranslasikan ip publik ke lokal maupun sebaliknya, agar client yang terhubung ke jaringan lokal yang kita buat dapat mengakses internet.
[admin@MikroTik] > /ip firewall nat
[admin@MikroTik] /ip firewall nat> add chain=srcnat out-interface=ether1 action=masquerade 
[admin@MikroTik] /ip firewall nat> add chain=srcnat out-interface=ether2 action=masquerade
4.Langkah terakhir yaitu buat gateway untuk koneksi dari rute yang sudah ditandai di mangle sebelumnya.
admin@MikroTik] > /ip route
[admin@MikroTik] /ip route> add dst-address=0.0.0.0/0 gateway=192.168.234.1 routing-mark=to_ISP check-gateway=ping 
[admin@MikroTik] /ip route> add dst-address=0.0.0.0/0 gateway=192.168.200.1 routing-mark=to_ISP2 check-gateway=ping
 - Nah untuk mengaktifkan Fail over pada metode PCC kita setting distance yang berbeda, apabila salah satu ISP down maka seluruh koneksi akan dialihkan ke ISP yang aktif.semakin kecil distance maka semakin di prioritaskan untuk pemilihan jalur.
[admin@MikroTik] /ip route> add dst-address=0.0.0.0/0 gateway=192.168.234.1 distance=1 check-gateway=ping 
[admin@MikroTik] /ip route> add dst-address=0.0.0.0/0 gateway=192.168.200.1 distance=2 check-gateway=ping
 5.jika berhasil selanjutnya tes pada client ether3 dan client ether4 dengan cara ping google.com (internet)




Kesimpulan 
dengan Load Balancing Menggunakan Metode PCC maka client ether3 mendapatkan koneksi dari ISP1 dan ether4 mendapatkan koneksi dari ISP2

Referensi 
http://www.mikrotik.co.id/artikel_lihat.php?id=34 

copas dari : https://maulanashio23.blogspot.co.id/2017/08/load-balancing-menggunakan-metode-pcc.html 

    Postingan terkait:

    Belum ada tanggapan untuk "Load Balancing Menggunakan Metode PCC (Per Connection Classifier)"

    Posting Komentar